Ubuntu下Eclipse的配置

2012年03月09日 分类:软件学习笔记C++Ubuntu

最近要学嵌入式,电脑上装了Ubuntu 12.04,gcc的命令行实在用的别扭,于是又装了Eclipse,但死活不能运行,总是有“launch failed. Binary file not found.”的错误。在网上找了一天终于解决了,写出来给大家看看。

首先安装Eclipse,可以到Ubuntu自带的软件中心搜索Eclipse,点击安装就行了。或者进入终端输入:

sudo apt-get install eclipse
sudo apt-get install eclipse-pde
sudo apt-get install eclipse-jdt

第一个是安装Eclipse,下面两个是他的插件,一般会自带,如果没有就装一遍吧。装好后就可以运行了,这时的Eclipse只能创建Java工程,要想让它支持c++还要装CDT(C/C++ Development Tooling),Eclipse是基于插件的IDE,要用什么功能就装什么插件。

Ubuntu Eclipse

进入Eclipse,Help->Install New Software,在Work with中输入http://download.eclipse.org/releases/galileo 等待读取软件列表,下面会出现一些Eclipse的插件包,展开Programming Languages,选中Eclipse C/C++ Development Tools,然后一路Next就行了。装好后他会提示重启Eclipse,确定。

现在再新建工程的时候就有c++ project的选项了,我新建了一个hello world后build,run,提示“launch failed. Binary file not found.”在debug文件夹下面也没有生成可执行包,上google,baidu,差不多所有的方法都试了一遍,什么改path啊,选PE什么的都没效果,Eclipse也卸了装了一遍,问题依旧。

再仔细分析一下,网上大都是debug文件夹下生成了可执行文件,只是在run的是有Eclipse没找到而已,而我是连可执行文件都没生成,这应该是编译器的问题。用命令行来编译可以通过,文件也生成了,难道Eclipse没有调用gcc。再去网上查下,可能是Eclipse的插件和gcc没有链接好,安装build-essential包就行了。

在终端中输入:

sudo apt-get install build-essential

提示错误,说依赖g++什么的,这Ubuntu依赖关系也太多了吧,装个软件都这么麻烦。继续google,好像是源的问题,找到一个不错的软件源网站http://ubuntu.uestc.edu.cn/ 找到与Ubuntu版本相对应的源,进入终端。

sudo gedit /etc/apt/sources.list
sudo apt-get update
sudo apt-get install build-essential

至此build-essential成功安装,再进入Eclipse,build,成功,run,终于可以hello world了

作者:wuyuan 本文来自Wuyuan's Blog 转载请注明,谢谢! 文章地址: https://wuyuans.com/2012/03/ubuntu-eclipse-c

近期文章

微信公众平台

分类目录

友情链接